WordSynk 2.0 - Add Location - Workaround Available

Incident Report for WordSynk

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 11:32 GMT

Update

Update: we want to give you some more information about the current incident affecting the 'Add Location' function within the Booking Form (Client Portal).
Our previous address‑data provider, getaddress.io, has ceased operations following a High Court ruling related to their use of third‑party address data. As a result, parts of our address‑lookup functionality may not work as expected at the moment.

What this means for you:
A temporary workaround is already available within the platform which allows you to create bookings.
We are actively implementing a permanent replacement service, and this will restore full functionality as soon as possible.
Thank you for your patience while we complete this fix.
Posted Feb 05, 2026 - 10:55 GMT

Identified

Users are seeing an error message (Venue Loading Failed) when trying to add the venue to a booking. Workaround: after typing the postcode, click into the other address boxes and manually type the address and click Add Location. This allows the booking to be created.
Posted Feb 04, 2026 - 16:34 GMT
This incident affected: WordSynk Client - Interpreting (WordSynk 2.0).