WordSynk 2.0 - Degraded Performance

Incident Report for WordSynk

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 08:04 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 09, 2026 - 16:45 GMT

Investigating

We are currently experiencing degraded performance of the WordSynk 2.0 Client Portal. We are urgently working on a fix.
Posted Feb 09, 2026 - 11:38 GMT
This incident affected: WordSynk Client - Interpreting (WordSynk 2.0) and WordSynk Customer Services (WordSynk 2.0 (UK)).