WordSynk Interpreting - Degraded Performance

Incident Report for WordSynk

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 09:01 BST

Investigating

We are investigating reports of degraded performance for the WordSynk Interpreting applications.
Posted Oct 15, 2025 - 08:49 BST
This incident affected: WordSynk Client - Interpreting (WordSynk 2.0).